Platform Outage
Incident Report for
SonoSuite
Resolved
The incident has been resolved
Posted
Dec
01
,
2025
-
11:30
CET
Update
We are continuing to investigate this issue.
Posted
Dec
01
,
2025
-
10:37
CET
Investigating
We’re currently experiencing an outage with the new app development, affecting Analytics, Royalties and Music sections. Our team is working to resolve the issue as quickly as possible. Thank you for your patience.
Posted
Dec
01
,
2025
-
10:37
CET
This incident affected: Website.
×
Subscribe to Incident
Subscribe to updates for
Platform Outage
via . You'll receive .